Tag Archives: jagged

Internet Explorer 7 pixelated images

Updated July 2008

Looks like this problem is happening more frequently and starting to happen for people’s entire system and not just their browser.  Let me first tell you why this is happening and then offer a few solutions.

You are experiencing this because you have a high resolution computer and the manufacturer is worried that the high resolution will result in you straining to see things on the screen.  Silly.  The good news is that it probably can be fixed.  Let’s try the easiest solution first.

Right click on the desktop and select “Properties” from the menu.

Select "Properties"
Select "Properties"

Then select the “Settings” tab and then click on the “Advanced” button near the bottom right.

Select the Settings tab and the Advanced button
Select the Settings tab and the Advanced button

Now in the display dialog window use the drop-down menu to change your DPI setting.  Now reboot your computer and see if that fixed the problem.

Change the DPI setting
Change the DPI setting

I use Firefox almost exclusively but sometimes i use Internet Explorer. Perhaps a website simply won’t work with Firefox, maybe my Firefox add-ons are preventing a portion of the page to load (every now and then i actually want to see the ads on a page), or maybe i’m checking on a website’s compatibility with IE. Whatever the reason, ever since installing IE7 on a Dell Inspiron 9400 the images in Internet Explorer have been pixelated. The text renders smoothly but not the images. Here’s the fix.

1. Close Internet Explorer and click “Start”.
2. Select “Run” and type in “regedit” without the quotes.
3. In the left hand column click on the plus sign next to “HKEY_CURRENT_USER”.
4. Do the same for Software, Microsoft, and Internet Explorer.
5. Click on “Main” and scroll down on the right side of the window to “UseHR”.

Regedit UseHR

6. Right click on “UseHR” and select “Modify” then change the “value data” to a zero instead of a one.
7. Restart IE and enjoy the non-jagged, newly smoothed web!

Before:
Internet explorer jagged images
After:
Internet Explorer smooth images

Some people have reported not having the UseHR line in their registry.  Try doing a search in the registry for UseHR.  Follow steps 1 and 2 and then click on “Edit” and “Find”.  Then follow steps 6 and 7.

If the three above solutions did not work to fix your grainy images then you can try adding the UseHR value.   Follow the steps above through to where “UseHR” should be. Right click in the right pane of the regedit window. It should say “New.” Mouse over that and then click on “DWORD value” and then name it UseHR. Then follow the rest of the steps.

Please post a comment if these don’t work for you.  And if it does fix your problem I’d love a comment also!